Installing rails-powerforce-api.md#

Download soure from github. Install to d:\rails\powerforce-api-master

cd <working dir>
bundle install

Same problem, dependency hell

D:\rails\powerforce-api-master>
D:\rails\powerforce-api-master>bundle install
Fetching gem metadata from https://rubygems.org/............
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Bundler found conflicting requirements for the Ruby  version:
  In Gemfile:
    Ruby

    listen (>= 3.0.5, < 3.2) was resolved to 3.1.5, which depends on
      rb-inotify (~> 0.9, >= 0.9.7) was resolved to 0.10.0, which depends on
        ffi (~> 1.0) was resolved to 1.10.0, which depends on
          Ruby  (< 2.7.dev) x64-mingw32

    nokogiri (= 1.10.3) was resolved to 1.10.3, which depends on
      Ruby  (>= 2.3) x64-mingw32

    pg (>= 0.18, < 2.0) was resolved to 1.1.4, which depends on
      Ruby  (>= 2.2) x64-mingw32

Ruby  (< 2.7.dev), which is required by gem 'pg (>= 0.18, < 2.0)', is not
available in the local ruby installation

D:\rails\powerforce-api-master>

So, after sorting through all the problems

> rails s
=> Booting Puma
=> Rails 6.0.0.rc1 application starting in development
=> Run `rails server --help` for more startup options
*** SIGUSR2 not implemented, signal based restart unavailable!
*** SIGUSR1 not implemented, signal based restart unavailable!
*** SIGHUP not implemented, signal based logs reopening unavailable!
Puma starting in single mode...
* Version 3.12.1 (ruby 2.6.6-p146), codename: Llamas in Pajamas
* Min threads: 0, max threads: 16
* Environment: development
* Listening on tcp://localhost:3000
Use Ctrl-C to stop
> rails db:migrate

Ensure you enter the pg password in database.yml